Swipe gesture intermittently unresponsive [FIXED IN v.1.5]

Bugs in ND1 (report'em, get'em fixed)

Swipe gesture intermittently unresponsive [FIXED IN v.1.5]

Postby tcab » Sun Apr 15, 2012 9:48 pm

Am using ND0 and am finding the swipe up and down gesture intermittently unresponsive.

It happens e.g. on the main stack display - whether it is normal size or maximised. When scrolling up or down, occasionally a swipe will not get recognised.
Whilst intermittent, it's still quite common and easy to reproduce. It makes the calculator experience feel unreliable.
I've also seen it happen in some other parts of ND0 e.g. Go to the Demos / Period to have the periodic table generated, and try swipe around to look at it. Every second or third swipe is ignored, leading to a frustrating experience.

I'm on a iPhone 4S and also have the exact same issue on the iPad (3rd gen).
tcab
 
Posts: 6
Joined: Sun Apr 15, 2012 9:28 pm

Re: Swipe gesture intermittently unresponsive

Postby oliver » Mon Apr 16, 2012 1:56 am

Hi tcab,

I see what you mean. This occurs when you start a second swipe right after ending one. The work-around is to allow for half a second or so between swipes.

This has to do with double-tap recognition on the HTML5 display object, which doesn't natively support it. If I remove the double-tap function, the problem goes away.

I confess I got so attuned to allowing for a little time between swipes, that I no longer noticed this. But I see how this can be annoying and will work on fixing this.

Thank you; that's great feedback!
oliver
Site Admin
 
Posts: 433
Joined: Sat May 01, 2010 2:11 pm


Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron