Nautical Mile (nmi) Constant Error [FIXED IN v.1.5]

Bugs in ND1 (report'em, get'em fixed)

Nautical Mile (nmi) Constant Error [FIXED IN v.1.5]

Postby SamyBean » Wed Jul 11, 2012 10:32 pm

There is an error in the defined constant for Nautical Mile [nmi]. Whenever I try to use this to convert to/from Mile [mi] or km (kilometer) I get the wrong result. It looks to me like the ND1 is treating "nmi" like "nano-mile" and NOT "Nautical Mile".
SamyBean
 
Posts: 2
Joined: Wed Jul 11, 2012 10:24 pm

Re: Nautical Mile (nmi) Constant Error

Postby oliver » Thu Jul 12, 2012 1:23 am

Hi Samy,

Yes, I can confirm the bug you're reporting: 'nmi' is seen as nano-mile instead of nautical mile. Sorry about that!

I need to see how to address this. You can fix this locally by doing the following:

1) Tap the My Data tab, tap Units
2) Tap the Edit button
3) Tap the Length [m] entry
4) Tap the Definition line and scroll quite a bit to the right until you come to the entry for "Nautical Mile [nmi]"
5) Change that text to "NauticalMile [Nmi]"
6) Tap the Save button, tap Done

You can now go back to the calculator tab and do a conversion like this
1
'mi'
'Nmi'

or
1
'mi'
'NauticalMile'

CONVERT


and it will correctly return 0.86897...

Hope this helps.

Oliver
oliver
Site Admin
 
Posts: 433
Joined: Sat May 01, 2010 2:11 pm

Re: Nautical Mile (nmi) Constant Error

Postby oliver » Tue Oct 08, 2013 11:26 pm

This class of conversion problems has been solved in v1.5.
Indeed, SI prefixes were used in preference to certain abbreviated unit names, yielded some (almost comical) units such as "nano-mile" or "femto-ton".
oliver
Site Admin
 
Posts: 433
Joined: Sat May 01, 2010 2:11 pm


Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron